小ネタ:WordPress 5.4で非推奨エラー(解決!)

サイトをWordpress 5.4へアップグレードしたら各記事の下に、

Deprecated: tag_link の使用はバージョン 2.5.0 から非推奨になっています ! 代わりに term_link を使ってください。

とメッセージが表示される様になりました!えっ何か間違った設定したっけと思ってネットで色々と調べたのですがどうもWordpress 5.4へアップグレードした時の問題の様です。

日本語サイトではまだ取り上げられていない様ですが、英語版Wordpressのサイトでは取り上げられていました。最善の改善方法はダウングレードだとの事ですが….簡単ではない気がします。私もちゃんとバックアップとかしていません。

対策方法や対応したバージョンがリリースされるまで調査と様子見の感じです。何かわかりましたらまた報告します。

2020年04月7日追記:

色々と解決方法を探したのですが、結局Wordpressのデバッグが有効になっている事で表示されるという事が分かりました。回避方法は、

  wp-config.php

ファイルの中にある。

  define(‘WP_DEBUG’, true);

の部分を、

  define(‘WP_DEBUG’, false);

とする事で回避できました。わかってしまえば簡単ですが、英語サイトとか色々と調べまわりました。